
Virtuoso 2.0 for NEXTSTEP Addendum

Welcome to Virtuoso 2.0 for NEXTSTEP. First of all, thank you for reading this Addendum. This
Addendum is not designed to make you read more documentation, but rather to inform you of 
the hot new features and enhancements, such as multiple pages, path operations, spell-checking, 
and many more. Use this Addendum with the Virtuoso User Guide for best results. 

Since its release in November 1992, Virtuoso has received praise for being the best graphics 
software available for NEXTSTEP. And in 1993, Virtuoso won the Best of the Breed Award from 
NeXTWorld Magazine and the Impact Award from Publish Magazine. So why change? Because 
we see much more room for improvement. You will see that the changes we’ve made will 
provide you with more flexibility to explore your creativity.    We hope you enjoy using Virtuoso 
2 as much as we enjoy bringing it to you.

Creating new documents (Chapter 1, pg. 27)

By default, Virtuoso creates new documents containing a single, letter-sized, page. If you 
frequently work with documents containing a different size, or number, of pages, you can change
this default setting. Just create a new document, add the number and sizes of pages you’d like to 
have, as well as anything else you frequently use, such as corporate logos, colors, etc. Name this 
document “default.vrt” and save it in your home directory. 
Every new document you create will now contain all the elements you saved in your defaults 
file. If you don’t need some of these elements in a particular document, you can always delete 
them. 

Multiple Pages (Chapter 1, pg. 28)

One of the most requested feature we’ve included in this version is the ability to create multiple 
pages in one document. You can even create several different page sizes within a single 
document. There’s no longer any need for you to switch back and forth between an illustration 
program with limited text capabilities and a page-layout program with poor drawing tools—
Virtuoso has all the features you need to create just about any kind of document. 

The Document Inspector

The Document Inspector now has two sections: Page Attributes and Document Attributes. In the 
Page Attributes section, you’ll find controls for setting the page sizes, orientation, and bleed 
areas of the pages in your document. This is where you add, copy, or remove pages. It’s also 
where you rearrange pages on the pasteboard. 

<show Page Attribute Inspector>

The settings in the Document Attributes section aren’t specific to a particular page—they apply 
to all the pages in the document. This is where you specify the units of measurement for the 
document, it’s also where you set up the “snaps” you want to work with, the size of the invisible 
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Snap-to grid, and the angle Virtuoso uses to constrain element movement when you’re holding 
down Shift. You can also set your Target Printer Resolution from this section.

Working with the Page Attributes Inspector
The Page Attributes section of the Document Inspector is the key to working with multi-page 
documents. To see it, display the Document Inspector, if it’s not visible, and click the Page 
Attributes button. 

<show Page Attributes button>

This is where you add, remove, or copy pages. It also contains the Pasteboard Previewer where 
you can rearrange the pages on the pasteboard.

<show Pasteboard Previewer>

You’ll see a large box in the Page Attributes section called the Pasteboard Previewer. The 
Pasteboard Previewer is a miniature representation of your document’s pasteboard, and the pages
on it. It provides a convenient way to organize and rearrange the pages in your document.

It’s easier to understand the relationship between the Pasteboard Previewer and the pasteboard in 
your document if you zoom out to 12% (choose 12% from the Magnification pop-up menu at the
bottom-left of the document window). Move the Inspector to one side so you can see both the 
Inspector and the pasteboard in the document window. Now, drag one of the page icons to a new 
location in the Pasteboard Previewer and you’ll see the corresponding page move to the same 
location on the pasteboard in the document window.
Tip: To quickly change the view in the document window to a particular page, double-click the 
page’s icon in the Pasteboard Previewer. The view moves to the page you clicked and the 
magnification setting is changed to “Fit.”

Each page icon in the Pasteboard Previewer has a number. These numbers don’t appear on the 
pages of your document when you print them, but you can use the numbers to specify a specific 
page, or range of pages, to print. For example, if you’re proof-printing, you might just need to 
print one or two pages of your document.

The page icons are numbered in rows, from left to right, starting at the top left. When you drag a 
page icon to a new location in the Pasteboard Previewer, Virtuoso renumbers all the icons to 
maintain the same left-to-right numbering pattern.

Important: When you drag a page’s icon to a new location in the Pasteboard Previewer, all the 
text and graphic elements on, or touching the page, move with it. This is usually what you want 
to happen, but you should be aware that anything extending off the edge of one page and 
touching an adjacent page will move when either page’s icon is dragged in the Pasteboard 
Previewer. You can prevent this by moving pages farther apart before you begin drawing on 
them, or by adjusting the elements of your document so they don’t touch adjacent pages.

Adding pages
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You can add pages to a new or existing Virtuoso document at any time.
To add pages to a document:
 1. Display the Page Attributes section of the Document Inspector, if its not already visible.
2. Choose “New Page” from the Options menu in the Document Inspector. Virtuoso displays 

the Add Pages panel.
3. Select the Tall or Wide option button to determine the orientation of the page. 
4. Choose the size for the new page from the Page size drop-down list. The list contains several 

commonly used sizes, but if you don’t see the size you’d like to use, choose Custom. When 
you choose “Custom,” the Add Pages panel displays x (width) and y (height) text boxes 
where you can specify the dimensions, in the current unit of measurement, for the new page.

5. The default bleed size setting is zero. If you want to change the setting, enter a new value in 
the Bleed size text box. For an explanation of the bleed size setting, see “The bleed area” in 
the User Guide.

6. To add several pages at one time, enter the number of new pages you want in the Number of 
pages text box. You can have as many pages as will fit on the pasteboard. For example, you 
can have a total of 24 letter-sized pages in one document. Obviously, if you’re working with 
tabloid-sized pages, you can have fewer pages. If you’re working with business cards, you 
can have many more. Look at the Pasteboard Previewer to tell how much space is still 
available on the pasteboard of a document.

7. Click OK to add the page(s) to your document or click Cancel to return to your document 
without adding any pages. Note: New pages are added in the upper left corner of the 
pasteboard when possible.

If you decide to change the size of a page after you’ve created it, click on its icon in the 
Pasteboard Previewer to select it (selected page icons have a dark border around them), and 
choose a different size from the Page size drop-down list, located just below the Pasteboard 
Previewer. If you choose Custom, the x and y text boxes are displayed in the Inspector so you 
can enter new dimensions for the page. You can also change the orientation of an existing page 
by selecting its icon in the Pasteboard Previewer and then selecting the Tall or Wide option 
button in the Inspector.

Tip: To make sure you’ve selected the right page before you change its size, double-click the 
Page icon you selected in the Pasteboard Previewer. The view in the document window changes 
to the page who’s icon you double-clicked, and the magnification is set to “Fit.”

Duplicating pages
When you select a Page icon in the Pasteboard Previewer and choose Duplicate Page from the 
Inspector’s Options menu, Virtuoso makes a copy of the page and everything on it, The new page
appears in the Pasteboard Previewer after all the other pages in the document, but you can drag it
to a different location if you prefer, The copied page has the same dimensions and orientation as 
the original. You’ll find Duplicate Page useful if you need to add a page that has the same 
column layout, or graphic elements as another page in your document. If you’re using a custom 
page size, duplicating a page is faster than adding a new page and then specifying the page’s 
dimensions.

Removing pages
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If you decide to delete a page, select its icon in the Pasteboard Previewer and choose Remove 
Page from the Inspector’s Options menu. If there are any graphic or text elements on the page, 
Virtuoso displays a message dialog to make sure you really want to delete the page.    Click OK 
to delete the page and everything on it, or click Cancel to return to your document without 
deleting the page. Note: If you have any objects hanging off the edge of the page, Virtuoso will 
delete the page without removing the those objects. These objects appear on the pasteboard.

If you delete a page with text linked to containers on other pages, the text isn’t deleted. It’s 
flowed back into the other linked containers. 

Tip: To make sure you’re deleting the right page, double-click the Page icon you selected in the 
Pasteboard Previewer. The view in the document window changes to the page whose icon you 
double-clicked, and the magnification is set to “Fit,” so you can see what’s on the page before 
you delete it.

Text container (Chapter 3)

(Page 194- 200) The text container when selected with the pointer tool now has four additional 
handles placed midway between the four corner handles. 

<show new text container>

When you click and drag on the left and right handles with the pointer tool, Virtuoso 
automatically adjusts the kerning of the text container. 

<show kerning example>

When you click and drag the bottom and top handles with the pointer tool, Virtuoso 
automatically adjusts the leading of the text container.

<show leading example>

(Page 227) When you double-click on an empty link box of a text container with the pointer tool,
Virtuoso automatically shrinks the container to fit the amount of text.

<show full size and fitted text container>

(Page 183) You can now use a pointer tool to place text insertion point in a text container. 
Normally, you would use a text tool’s I-beam to place an insertion point, but we added this new 
feature to give you more tool flexibility. 
To place a text insertion point in container with the pointer tool:
• Select the text container with the pointer tool.
• Double-click with the pointer tool on the area where you want the text insertion point.
Virutoso then places an insertion point, changes the pointer tool to the text tool, and you are 
ready to type away—without having to reselect the text tool. 
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To deselect a text container with an insertion point in it:
• Hold down Command + Tab. Virtuoso will deselect the container automatically— you do not 
have to select the pointer tool.

Printing Multiple Pages (Chapter 7, pg. 366)

You can choose to print one page of your document or several pages in order as they appear in 
the Pasteboard Previewer of the Page Attributes Inspector. In the Print Panel, select “All” to print
entire document or enter specific “From” and “To” page numbers print certain pages of your 
document.

<show new Print Panel>

Saving Pages (Chapter 1, pg. 29)

We have included a new command under the Document menu called “Saving Pages...”. This 
command allows you to save all or a range of pages as an EPS file, Adobe Illustrator 88 or 
Adobe Illustrator 3 file. Simply choose “All” or enter values in the “From” and “To” text boxes. 
Virtuoso automatically appends the number symbol (#) after the file name to mark the different 
pages. 

Exporting Multiple Pages (Chapter 4, pg. 269) 

When you export a multiple paged document to EPS format, Virtuoso will make an EPS file for 
each page of your document. For example, if you have a five page document and export it to EPS
format, Virtuoso will make five separate EPS files.Virtuoso will automatically append a number 
after the name of the document such as Car.eps-1, Car.eps-2, etc.

<show Export panel?>

Exporting a multiple page Virtuoso 2    document to Aldus FreeHand 3.1 format will result in a 
single page document. Because FreeHand 3.1 does not support multiple pages, Virtuoso simply 
merges all elements of the document on to one 40” x 40” page. 

When you export a multiple page Virtuoso 2 document to Adobe Illustrator 88 and 3 formats, be 
aware that Virtuoso will only export page 1 of your document, and the information on all 
subsequent pages is lost.    

Editable EPS files (Working with Virtuoso Files in Other Application, pg. 273)

Virtuoso 2 now can open its own generated EPS files. When you export any Virtuoso 2 document
to EPS format, you can later open that EPS file and edit it as a normal Virtuoso 2 document. For 
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this feature to work, you must edit the preferences using dwrite. Use the following commands: 
“dwrite Virtuoso EmbedDocInEPS Yes” and “dwrite Virtuoso CrackPlacedEPS Yes”. 
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Path Utilities

In this latest version of Virtuoso, we’ve included ten new path utilities designed to simplify the 
creation of paths or unique shapes. Located in the Path menu under the Arrange menu, these path
utilities include: Correct Direction, Reverse Direction, Simplify, Remove Overlap, Punch, 
Intersection, Union, Inset, Stroke, and Translucency.

<shot of menus>

Note: Although Blend is included as path utility, it is not a new feature. We simply moved its 
location to Path menu.

We will proceed with an explanation of each of these new path utilities.    

Correct Direction

This utility does exactly as its name suggests—it corrects path directions. Each path has either a 
clockwise or counterclockwise direction depending on how it was created, and each path acts 
differently depending on its direction. For example, the letter “O” when converted to paths is a 
composite path with two subpaths that have opposite directions. The result of the opposing 
direction is the donut-hole effect. If you have composite paths with subpaths going in the same 
direction, select the composite path, choose Correct Direction, and Virtuoso will calculate the 
proper combination of path directions. 

<maybe an illustration showing before and after correct direction>

Reverse Direction

Reverse Direction changes the direction of a path—either clockwise or counterclockwise. You 
might think “why would you need to change a path’s direction?” There are many instances where
it would come in very handy. For example, if you apply a Border line style to a path, the 
direction of the border follows around the path is the same as the path’s direction. You might find
that your carefully-drawn path has the right shape, but the border is running in the wrong 
direction. You would select the path, choose Reverse Direction from the Path menu, and the 
border changes to run in the opposite direction.

If you bind text to a path, you probably want your text to run right-side up along the path in most
cases. If the path wasn’t really draw in the right direction, though, you might find your text is 
upside down and backwards. Select the path, choose Reverse Direction, and the text will appear 
right-side up and running along the path. The process is the same if you happen to want your text
running upside down and backwards. 
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In the following example, you can see that Reverse Direction is helpful in changing which end a 
path has an arrowhead.

<show reverse direction with two paths and arrowhead>

Simplify

When you choose Simplify from the Path menu, Virtuoso removes unneeded points from any 
selected path, without significantly changing the path’s shape. Simplify can be used repeatedly 
until you come to a point where no more points can be removed without altering the shape of the 
path. If paths can’t be simplified further, they are left unchanged.

<show before and after illustration of path>

If you later decide that you’ve removed too many points, you can add points to a path with the 
pen or bezigon tool.

Remove Overlap

When you create self-intersecting closed paths, like the ones produced by the calligraphic or 
variable-weight pen tools, you have overlapping areas. You can easily remove these self-
intersecting areas with Virtuoso’s Remove Overlap command under the Path menu. When you 
choose Remove Overlap, Virtuoso removes only the portions of the selected path that cross over 
each other, and leaves the rest of the path unchanged. Remove Overlap can be used on any self-
intersecting closed path, not just those drawn with calligraphic or variable-weight pen tools. 

<show illustration of remove overlap>

Punch

Punch is fun path utility that acts much like a cookie cutter. If you arrange two or more closed 
paths so they overlap, select them, and choose Punch from the Path menu, Virtuoso then takes 
the topmost path and “knocks” through the paths underneath. If the topmost path is arranged so 
that it fits entirely within the paths below, rather than overlapping their edges, a composite path 
is created. To make text “punch” through other elements, you must first convert the text to paths, 
then choose Punch.

<show illustration of punch>

Intersect

This path utility creates a new path out of overlapping areas of two or more closed paths. You 
must arrange the closed paths until the area where they overlap has the shape of the new path you
want to create. Select all the paths, then choose Intersect from the Path menu, and Virtuoso 
creates a new path out of the where all the closed path share.    The original paths are then 
removed, leaving only the new path, which takes on the fill and stroke of the backmost path. 

Altsys Virtuoso 2 Addendum 8 February 12, 2023



<show illustration of intersect>

Union

The Union command is an easy one-step process to creating complex shapes. Union combines 
selected overlapping two or more closed paths and makes a new closed path. You must arrange 
the multiple paths so that the outline of all the paths has the shape of the new path you want to 
create. Select all the paths, and choose Union from the Path menu. Virtuoso then creates a single,
closed path that follows the outline of all of the selected paths. The original paths are then 
removed, leaving the new path, which takes on the fill and stroke of the backmost original path.

<show illustration of Union>

Inset

The Inset command is used to shrink or expand closed paths. By choosing Inset, you are 
adjusting the distance around the edge of a closed path by a particular point size. For example, if 
you want to enter 10 points, the path will be shrunk so that it moved in 10 points on all sides 
from the current location. Inset is not the same as scaling because scaling proportionally reduces 
and enlarges.

<show difference between scaling and inset in the same image>

When you select one or more closed path, and choose Inset from the Path menu, Virtuoso 
displays the Inset Paths panel. If you enter a negative number, and the closed path will be 
expanded by the amount you entered. If you enter a positive number, the closed path will be 
decreased in size by the amount specified.

<show Inset Paths panel>

In the Inset Paths panel, you also have the option to set the line join and the miter limit. The Line
Join buttons determine the way line segments in the path meet at a corner point. If you select 
Miter (the left button), line segments will meet in a sharp point. If you select Round (the middle 
button), the point where line segments meet will be rounded over. If you select Beveled (the right
button), the point where line segments meet will be flattened.

The Miter Limit text box determines when a mitered join is replaced by a beveled join. The 
number you enter in the text box sets the maximum width of the corner, as a multiple of the line 
weight, that you’ll allow.

Stroke
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The Stroke command allows you to expand the stroke or outline any selected closed or open 
path. Stroking is not the same as expanding the width of your path. When you stroke a closed 
path, Virtuoso creates a composite path. When you stroke an open path, Virtuoso creates a closed
path. 

<show open path, expanded width by 48 pts, & stroked path by 48 points.>

When you choose Stroke from the Path menu, Virtuoso displays a Stroke Paths panel. 

<show the Stroke Paths dialog>

Enter a number in the Width box, and Virtuoso creates an outline of the path at the specified 
number. The Line Cap buttons determine the way the ends of an outline are drawn when the 
Stroke command is used on an open path. If you select Butt Cap (the left button), the outline 
ends flush with each end of the selected path. If you select Round Cap (the center button), the 
outline extends beyond each end of the path by half the distanced entered in the Width text box, 
and is rounded over. If you select Square Cap (the right button), the outline extends beyond each 
end of the selected path by half the distance entered in the Width text box, but is square.

The Miter Limit buttons and Miter Limit text box work the same as those found in the Inset 
panel.

Make Translucent 

The Make Translucent command allows you to create new translucent closed paths from 
overlapping areas of two or more closed paths. Given several overlapping closed paths, Make 
Translucent takes the topmost path and punches through the bottom paths creating a new path 
with each lower path. If you have “n” overlapping closed paths, Make Translucent will give you 
“n-1” new paths because it performs a separate intersection between the topmost path and each 
path below it. The original paths remain unchanged.

<show illustration of 3 overlapping paths and 2 new translucent paths>

When you choose Make Translucent from the Path menu, Virtuoso displays a Make Translucent 
panel that allows you to use the slider bar to adjust transparency of the topmost path, relative to 
the paths beneath it. You can also enter a value in the Opaque text box. For example, if you select
three overlapping closed paths with three different colors, choose Make Transparent, and enter 
25 in the Opaque text box, Virtuoso compares the values of the topmost path with each 
intersecting bottom paths. Virtuoso then creates two new closed paths that are 25% transparent 
and 75% opaque. It’s difficult to illustrate this path utility using a grayscale image, but hopefully 
the illustration below will help you understand it better.

<show Make Translucent panel>

NEXTSTEP Services
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Spell Checking

Virtuoso now supports NEXTSTEP’s spell checking capabilities. If you are unsure how to use 
Spell Check, refer to the NEXTSTEP User’s Guide for details.

Object Linking

Virtuoso 2 now supports NEXTSTEP’s object linking both as a link provider and a link acceptor.
Refer to your NEXTSTEP User’s Guide if you are not familiar with Object linking.

Filter Services

Virtuoso 2 also supports NEXTSTEP’s filter services. Refer to your NEXTSTEP User’s Guide 
for more information on Filter Services.

Preferences

You can change preferences by using dread and dwrite. These preferences are “hidden,” so you 
must have knowledge of UNIX to change these preferences, which are listed below.

ViewingSetsActivePage Yes: If page “x” is the main page on-screen, it automatically becomes 
active. Or if you zoom in on a page, it becomes the active page whether or not you clicked on it. 
To set this preference so that it does not occur, use dwrite to change “Yes” to “No”.

ToolsSetActivePage Yes: When you use any tool on a given page “x”, that page becomes active. 
When you turn this preference “No”, page “x” is always going to be active even when you use a 
tool on another page. 

TiffModePrintOverride 1: Leaving the default in this setting means Virtuoso print your document
using the setting you inputed in the Output Options panel. Use dwrite to change “1” to “2” and 
Virtuoso will override the Output Options panel and always image data in binary. If you use “3”, 
Virtuoso forces the image data to ASCII. 

NewStylesTakeCurProps No: When it is set to “Yes,” you can set new style based on those 
properties of a selected element. This preference is currently set to “No.” 

NewStylesAutoApply No: Turn this preference on if you want Virtuoso to automatically apply a 
newly created style to a selected element. Its default is “No.”

EmbedDocInEPS No: This preference automatically allows you to create Virtuoso 2-generated 
EPS files that can be opened by Virtuoso 2. Use dread and dwrite to turn it on by typing “Yes”.

CrackPlacedEPS No: This preference allows you to open the Virtuoso EPS files that were 
created with EmbedDocInEPS. Normally, this preference is turned off, but you can type in “Yes”
to activate the feature.
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AlwaysEmbedImports No: This preference forces Virtuoso to embed any placed files into the 
Virtuoso document. This means that all your placed files will stay with the document, and when 
you change the original file, the placed files will remain unchanged. You must realize that your 
files will increase in size rather quickly. To use this preference, set it to “Yes”.

DefaultPPDNeXT_400_dpi_Laser_Printer.ppd: This preference automatically sets the default 
printer PPD. If you want to change the ppd, simply use dwrite to type in a new printer PPD. 

PPDDirectory/NextLibrary/PrinterTypes/English.lproj: This preference allows you to set your 
own default PPD directory.

Virtuoso 2 Enhancements
In this version of Virtuoso, we have greatly improved Virtuoso’s stability. We made changes that 
may go unrecognized, but here’s a list of important changes that we thought you might be 
interested in knowing about.

• We improved the relationship between elements on duplicated layers. When you alter any 
element on the original layer, the same element on duplicated layer is unaffected.    

• Printing to PS Level 1 printers has been enhanced.

• We developed a work-around for a problem in NEXTSTEP 3.0 where Pantone® colors do 
not correctly translate to CMYK. This problem is corrected in NEXTSTEP 3.1.

• We fixed problem with the Variable weight freehand where tool stops varying after any other 
action if you use the keyboard to simulate pressure. Also, Virtuoso continues to run if you 
hold down Alternate and Shift and click once with this tool.

• Virtuoso now uses the NEXTSTEP Expert preferences File-creation mask when saving.

• Virtuoso now allows you to enter values in tenths in the Transform panel.

• Grayscale TIFFs now print when tints of spot colors are applied to them.

• Tiling now works if you don't pick a PPD.

• Bind to path and Flow in path commands are now grayed out when elements are locked.

• Kerning information is retained when importing Aldus FreeHand 3.1 documents into 
Virtuoso.

• Color information that is applied to text is now retained when copying text from Virtuoso 
into other applications which support RTF.

Altsys Virtuoso 2 Addendum 12 February 12, 2023



• We vastly improved the printing of custom pages and the reading of information from PPDs. 
Virtuoso now uses the PPDs installed with NEXTSTEP.

• You can no longer link text into a locked container.
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